Degraded Experience – New CMK (Crusoe Managed Kubernetes) Node Pool Expansion

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 23:14 UTC

Investigating

We are aware of an issue with an upstream dependency that may impact the ability to add new nodes to existing node pools. Existing clusters and running workloads are not affected.

We are actively monitoring the situation and will provide updates as it progresses. If you are experiencing issues, please contact Crusoe Support.
Posted Mar 30, 2026 - 21:12 UTC
This incident affected: Orchestration (Crusoe Managed Kubernetes (CMK)).