VM Connectivity and Performance Degradation in the Iceland Region

Incident Report for Crusoe Cloud

Resolved

Issue resolved.
Posted Nov 04, 2025 - 19:46 UTC

Monitoring

We have mitigated the issue and connectivity is confirmed to be restored. We will monitor overnight.
Posted Oct 30, 2025 - 06:10 UTC

Identified

We have identified the issue and are deploying a fix.
Posted Oct 30, 2025 - 04:55 UTC

Update

We are continuing to investigate this issue.
Posted Oct 30, 2025 - 02:36 UTC

Update

We have isolated the issue to a subset of VMs within the Iceland region and determined that it is not a core network transport failure.

Our Engineering teams are continuing to actively troubleshoot the issue to restore service as soon as possible.
Posted Oct 30, 2025 - 02:35 UTC

Investigating

We are currently investigating an incident affecting VM connectivity and performance in the Iceland region.

Our Engineering teams are actively engaged and working to isolate the root cause. We will provide updates as our investigation progresses.
Posted Oct 30, 2025 - 00:46 UTC
This incident affected: Networking (Datacenter Networking).