Shared Disks Unreachable in eu-iceland1 region

Incident Report for Crusoe Cloud

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 21:05 UTC

Monitoring

The issue has been mitigated and is now operating normally. We are monitoring the system to ensure continued stability.
Posted Feb 27, 2026 - 05:36 UTC

Update

We are continuing to investigate this issue.
Posted Feb 27, 2026 - 04:58 UTC

Investigating

We are currently investigating an issue impacting our Shared Disks in the eu-iceland1-a region.

We are actively working with our storage vendor to resolve this issue. We will provide another update as soon as we have more information.
Posted Feb 27, 2026 - 04:58 UTC
This incident affected: Storage (Shared Disks).